What mobile devices is Electri 5 Casino compatible with?

  • Our iOS app requires iOS 8.0 or later and is compatible with iPhone, iPad, and iPod touch. This app is optimized for iPhone 5.
  • Our Android app requires an operating system of 4.1.1 (Jellybean) or higher
Have more questions? Submit a request

Comments

Powered by Zendesk